<!DOCTYPE html>
<html class="no-js" lang="en-UK" dir="ltr"    >
<head >
<meta charset="UTF-8">
<title >10 of the best: pubs along Peak Forest & Ashton canals | Canal Boat</title>
<meta name="description" content="Our insiders guide to 10 of the best pubs to be found along Peak Forest &amp; Ashton canals that you can visit while holidaying in your narrowboat boat. ">
<meta name="viewport" content="width=device-width, initial-scale=1">
<link rel="shortcut icon" href="/resource/blob/3844940/6536b46a3f61f7a8c3c993c1eb75eb31/canal-boat-home-page-favicon.ico" ><link rel="canonical" href="https://www.canalboat.co.uk/waterways/10-best-pubs-along-peak-forest-ashton-canals-8689168" />
<script>document.documentElement.className = document.documentElement.className.replace(/no-js/g, "js");</script>
<script>
function addStyle(linkId, linkHref) {
let headElem = document.getElementsByTagName('head')[0];
let linkElem = document.createElement('link');
linkElem.id = linkId;
linkElem.rel = 'stylesheet';
linkElem.href = linkHref;
headElem.appendChild(linkElem);
}
addStyle("roboto","https://fonts.googleapis.com/css?family=Roboto:300,400,500");
addStyle("materialicons","https://fonts.googleapis.com/icon?family=Material+Icons");
addStyle("fontawesome","https://use.fontawesome.com/releases/v5.8.1/css/all.css");
</script>
<noscript>
<link rel="stylesheet" href="https://fonts.googleapis.com/css?family=Roboto:300,400,500&display=swap" />
<link rel="stylesheet" href="https://fonts.googleapis.com/icon?family=Material+Icons" />
<link rel="stylesheet" href="https://use.fontawesome.com/releases/v5.8.1/css/all.css" />
</noscript>
<link href="/resource/themes/archant-shared/css/canal-boat-7305088-21.css" rel="stylesheet" >
<meta name="title" content="10 of the best: waterside pubs along Peak Forest & Ashton canals" />
<meta property="og:url" content="https://www.canalboat.co.uk/waterways/10-best-pubs-along-peak-forest-ashton-canals-8689168" />
<meta property="og:image" content="https://images.cm.archant.co.uk/service/social-media-image/3844940/8689462/1/6217232-2/strawberry%20duck%20pub%20at%20clayton.jpg" />
<meta property="og:description" content="
Our insiders guide to 10 of the best pubs to be found along Peak Forest &amp;amp; Ashton canals that you can visit while holidaying in your..."/>
<meta property="article:section" content=""/>
<meta property="og:type" content="Article" />
<meta name="twitter:card" content="photo"/><meta property="og:title" content="10 of the best: waterside pubs along Peak Forest &amp; Ashton canals" />
<meta property="article:author" content=" Martin Ludgate"/>
<meta property="article:published_time" content="2022-02-14T11:23:04"/>
<meta property="article:modified_time" content="2022-02-14T11:23:04"/>
<meta name="robots" content="max-snippet:-1">
<meta name="robots" content="max-image-preview:large">
<meta name="robots" content="max-video-preview:-1">
<meta name="twitter:card" content="photo"/> <meta property="og:description" content="" />
<meta property="og:site_name" content="Canal Boat" />
<meta name="google-site-verification" content="-Hr-NN3Xz8RCkMx6wFEst8UER8pHY1w7SpKcxHPZXG8" />
<meta name="referrer" content="origin-when-cross-origin" />
<meta name="theme-color" content="#FFFFFF" />
<meta property="fb:pages" content="886437734801332" />
<script type="application/ld+json">
{
"@context": "http://schema.org",
"@type": "NewsArticle", "mainEntityOfPage": "https://www.canalboat.co.uk/waterways/10-best-pubs-along-peak-forest-ashton-canals-8689168",
"headline": "10 of the best: pubs along Peak Forest &amp; Ashton canals",
"name": "10 of the best: waterside pubs along Peak Forest & Ashton canals",
"articleSection": "Waterways",
"description": "Our insiders guide to 10 of the best waterside pubs to be found along Peak Forest & Ashton canals. Read our cruise guide for the Peak Forest & Ashton canals here The Strawberry Duck, Clayton 07931 170307 By Lock 13 Smart, friendly, traditional...",
"wordCount": "343",
"articleBody": "Our insiders guide to 10 of the best waterside pubs to be found along Peak Forest & Ashton canals. Read our cruise guide for the Peak Forest & Ashton canals here The Strawberry Duck, Clayton 07931 170307 By Lock 13 Smart, friendly, traditional pub with modern extension, canalside outdoor seating, real ale, live music at weekends More info The Boundary, Guide Bridge 0161 612 0754 By Bridge 26 Gastropub with wide range of food but also welcomes those wanting a drink. Real ale, garden More info The Cheshire Ring, Manchester Road Hyde 07917 055629 Just east of Bridge 6 Name commemorates the canal circuit. Selection of real ales from local microbreweries, ciders and European beers. Monthly Laurel & Hardy film night. Closed Mon-Thu lunchtimes More info The Spread Eagle, Hatherlow, Romiley 0161 494 5723 2 mins west of the aqueduct over Green Lane Large family friendly pub with good value food and range of real ales More info The Navigation, Marple Just west of Bridge 18 Lively community local with real ale and food More info The Samuel Oldknow, Market Street, Marple 07766 301627 5 mins west of Bridge 18 and left Quirky little pub in converted shop, named after businessman involved in building the canal, good selection of real ales and ciders, snacks (local pies) More info The Rock Tavern, Wirksmoor Road, New Mills 01663 746430 5 mins north east from Bridge 28, left into Torvale Road and right Back street local tucked away on way to Riverside Park. Real ale, garden More info Soldier Dick, Buxton Road, Furness Vale 01663 611010 5 mins west of Bridge 31 and right Comfortable traditional pub with open fire, range of real ales and garden More info The Navigation, Bugsworth 01663 732072 By the upper basin Family friendly traditional multi-room pub, real ale, good value food all day, outdoor seating and play area More info The Goyt, Bridge Street, Whaley Bridge 01663 732710 5 mins south from basin along Canal Street and left Friendly town local with selection of real ales and garden More info",
"image": "https://images.cm.archant.co.uk/resource/blob/8689462/5967548f7a4a33030716be44e970df53/strawberry-duck-pub-at-clayton-data.jpg","datePublished": "2022-02-14T11:23:04",
"dateModified": "2022-02-14T11:23:04",
"author": {
"@type": "Person",
"name": "Martin Ludgate"
},
"publisher": {
"@type": "NewsMediaOrganization",
"name": "Archant",
"url": "https://www.canalboat.co.uk",
"logo": {
"@type": "ImageObject",
"url": "https://www.canalboat.co.uk/resource/crblob/7304874/40d9813dc0cd081d4deb0836e847f9b3/cnb-masthead-svg-data.svg"
}
}
} }
</script>
<script type="text/plain" class="optanon-category-C0004">
!function(a,e){a.cca=a.cca||{},a.cca.tapPrebidQue=[],a.cca.tapGAMQue=[];var n=a.cca;a.pbjs=a.pbjs||{que:[]};var t=a.pbjs;t.que.push(function(){t.onEvent("bidWon",function(a){n.tapReady||n.tapPrebidQue.push(JSON.stringify(a))})}),a.googletag=a.googletag||{cmd:[]};var c=a.googletag;c.cmd.push(function(){c.pubads().addEventListener("slotRenderEnded",function(a){n.tapReady||n.tapGAMQue.push(a)})})}(window);
</script>
<script type='text/plain' class='optanon-category-C0001' src="https://confiant-integrations.global.ssl.fastly.net/UHHHXz-vnh6BKLOE_WFsgn6yNQY/gpt_and_prebid/config.js"></script>
<script type="text/plain" class="optanon-category-C0001" async src="https://securepubads.g.doubleclick.net/tag/js/gpt.js"></script>
<script>
var googletag = googletag || {};
googletag.cmd = googletag.cmd || [];
googletag.cmd.push(function () {
if (googletag.pubads().getTargeting('carbon_segment').length === 0) {
var carbon = JSON.parse(window.localStorage.getItem('ccRealtimeData'));
googletag.pubads().setTargeting('carbon_segment', carbon ?carbon.audiences.map(function (i) { return i.id; }) : []);
}
});
</script>
<script type="text/plain" class="optanon-category-C0001">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</script>
<script type='text/plain' class='optanon-category-C0004'>
! function(a9, a, p, s, t, A, g) {
if (a[a9]) return;
function q(c, r) {
a[a9]._Q.push([c, r])
}
a[a9] = {
init: function() {
q("i", arguments)
},
fetchBids: function() {
q("f", arguments)
},
setDisplayBids: function() {},
targetingKeys: function() {
return []
},
_Q: []
};
A = p.createElement(s);
A.async = !0;
A.src = t;
g = p.getElementsByTagName(s)[0];
g.parentNode.insertBefore(A, g)
}("apstag", window, document, "script", "//c.amazon-adsystem.com/aax2/apstag.js");
apstag.init({
pubID: '3953',
adServer: 'googletag'
});
apstag.fetchBids({
slots: [{
slotID: 'ad-slot-lb',
slotName: '/154725070/canalboat/waterways',
sizes: [
[320,50],
[728,90],
[970,250]
]
},{
slotID: 'ad-slot-mpu-1',
slotName: '/154725070/canalboat/waterways',
sizes: [
[300,250],
[300,600]
]
},{
slotID: 'ad-slot-mpu-2',
slotName: '/154725070/canalboat/waterways',
sizes: [
[300,250]
]
},{
slotID: 'ad-slot-mpu-3',
slotName: '/154725070/canalboat/waterways',
sizes: [
[300,250]
]
},{
slotID: 'ad-slot-mpu-4',
slotName: '/154725070/canalboat/waterways',
sizes: [
[300,250]
]
},{
slotID: 'ad-slot-mpu-5',
slotName: '/154725070/canalboat/waterways',
sizes: [
[300,250]
]
}],
timeout: 2e3
}, function(bids) {
googletag.cmd.push(function() {
apstag.setDisplayBids();
});
});
</script>
<script>
var carbonRealtime = JSON.parse(window.localStorage.getItem('ccRealtimeData'));
var ozoneSettings = {};
var ozoneTargeting = {
carbon_segment: (carbonRealtime) ? carbonRealtime.audiences.map(x => (x.id)) : []
}
</script><script type='text/plain' class='optanon-category-C0004' async src="https://ads.rubiconproject.com/prebid/11022_Archant_test.js"></script>
<script type='text/plain' class='optanon-category-C0004' >
var pbjs = pbjs || {};
pbjs.que = pbjs.que || [];
var dmSizeMappings = {
"ad-slot-lb": [
{ minViewPort: [320, 0], sizes: [320, 50] },
{ minViewPort: [648, 0], sizes: [728, 90] },
{ minViewPort: [1020, 0], sizes: [[728, 90], [970, 250]] }
]
};
var dmSlotsInitialLoad = headerBiddingSlotsInitialLoad;
googletag.cmd.push(function() {
pbjs.rp.requestBids({
callback: sendAdServerRequest,
sizeMappings: dmSizeMappings,
gptSlotObjects: dmSlotsInitialLoad,
data: {
ozoneSettings,
ozoneTargeting
}
});
});
function sendAdServerRequest(headerBiddingSlots) {
if (pbjs.adserverRequestSent) return;
pbjs.adserverRequestSent = true;
googletag.pubads().refresh(headerBiddingSlots, { changeCorrelator: false });
}
setTimeout(function() {
sendAdServerRequest(dmSlotsInitialLoad);
}, 3500);
function requestBidsAndRefresh(adObjArr) {
googletag.cmd.push(function() {
pbjs.que.push(function() {
pbjs.rp.requestBids({
callback: sendAdServerRequestLocal,
sizeMappings: dmSizeMappings,
gptSlotObjects: adObjArr,
data: {
ozoneSettings,
ozoneTargeting
}
});
});
var adserverRequestSentLocal;
function sendAdServerRequestLocal(headerBiddingSlots) {
if (adserverRequestSentLocal) return;
adserverRequestSentLocal = true;
googletag.pubads().refresh(headerBiddingSlots, { changeCorrelator: false });
}
setTimeout(function() {
sendAdServerRequestLocal(adObjArr);
}, 3500);
});
}
function fetchAdByDivId(adSlotId){
console.log("Coremedia > headerBidDemandManager > call ad ID " + adSlotId);
requestBidsAndRefresh([headerBiddingSlotsBottomFeed[adSlotId]]);
}
</script>
<script src="https://tags.crwdcntrl.net/c/4781/cc.js?ns=_cc4781" id="LOTCC_4781"></script>
<script>
// Adding Natural Language Processing (NLP) article data if available
// #if($m.local.article && $m.local.article.nlpcategory.value != "")
// _cc4781.add("genp","$!m.local.article.nlpcategory.value");
// #end
if (typeof _cc4781 !== 'undefined') {
console.log("_cc4781 available, calling bcp()");
_cc4781.bcp();
} else {
console.warn("_cc4781 was undefined, you may want to check that again...");
}
</script>
<script>
dataLayer = [ {
"Global" : {
"PlatformType" : "CoreMedia",
"PlatformVersion" : "2004.2",
"PlatformEnvironment" : "Live"
},
"Site" : {
"Name" : "Canal Boat",
"Id" : "CanalBoat.c",
"Domain" : "https://www.canalboat.co.uk",
"DfpAdsEnabled" : true,
"Type" : "News",
"GoogleAnalyticsId" : "UA-63563506-2",
"NanoInteractive" : "5c0f7ba80ae899484b0cf3ff",
"OneTrustSiteId" : "a62bb73c-c623-4a53-be56-c818c9575c92",
"PrebidTimeout" : 8000
},
"Page" : {
"Name" : "10 of the best: waterside pubs along Peak Forest & Ashton canals",
"Title" : "10 of the best: waterside pubs along Peak Forest & Ashton canals",
"Type" : "Article",
"Section" : "waterways",
"SearchTerms" : ""
},
"Article" : {
"Id" : "8689168",
"Slug" : "10-of-the-best:-waterside-pubs-along-peak-forest-&-ashton-canals",
"AuthorName" : "Martin Ludgate",
"AuthorEmail" : "",
"Categories" : "Waterways",
"MainCategoryId" : "Waterways",
"Tags" : "",
"PublishDateEpoch" : 1644837784000,
"PublishDate" : "2022-02-14T11:23:04+0000",
"ModifiedDateEpoch" : 1644837784000,
"ModifiedDate" : "2022-02-14T11:23:04+0000",
"WordCount" : 343,
"Title" : "10 of the best: waterside pubs along Peak Forest & Ashton canals",
"SeoTitle" : "10 of the best: pubs along Peak Forest & Ashton canals",
"Description" : "Our insiders guide to 10 of the best pubs to be found along Peak Forest & Ashton canals that you can visit while holidaying in your narrowboat boat. ",
"CanonicalUrl" : "/waterways/10-best-pubs-along-peak-forest-ashton-canals-8689168",
"Status" : "",
"IsNews" : false,
"Urn" : 0,
"IsCanonical" : true,
"ImgUrl" : "/resource/blob/8689462/5967548f7a4a33030716be44e970df53/strawberry-duck-pub-at-clayton-data.jpg"
},
"Omniture" : {
"Account" : "archantcanalboatmag",
"McOrgId" : "2C000C3A53DA83BF0A490D4D@AdobeOrg",
"Server" : "archant.d3.sc.omtrdc.net",
"VisitorApiUrl" : "https://www.canalboat.co.uk/resource/themes/archant-shared/vendor/VisitorAPI-7305072-1.js",
"AppMeasurementUrl" : "https://www.canalboat.co.uk/resource/themes/archant-shared/vendor/AppMeasurement-7305074-1.js",
"s_prop1" : "Waterways",
"s_hier1" : "Waterways"
}
} ];
</script>
<!-- Google Tag Manager -->
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-M6H5MVF');</script>
<!-- End Google Tag Manager -->
<script src="https://cdn.cookielaw.org/consent/tcf.stub.js" type="text/javascript" charset="UTF-8"></script></head><body class="mdc-typography" >
<!-- Google Tag Manager (noscript) -->
<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-M6H5MVF"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<!-- End Google Tag Manager (noscript) --><aside class="mdc-drawer mdc-drawer--modal">
<div class="mdc-drawer__content">
<nav>
<div class="mdc-list">
<div class="mdc-list__item-container">
<div class="mdc-list__item-primary">
<a class="mdc-list-item" href="/news" ><span class="mdc-list-item__text">News</span></a> </div>
</div><div class="mdc-list__item-container">
<div class="mdc-list__item-primary">
<a class="mdc-list-item" href="/boats" ><span class="mdc-list-item__text">Boats</span></a> <div class="mdc-list-item__meta">
<button class="mdc-icon-button material-icons">arrow_drop_down</button>
</div>
</div>
<div class="mdc-list mdc-list__nested">
<div class="mdc-list__item-container">
<div class="mdc-list__item-primary">
<a class="mdc-list-item" href="/boats/boat-tests" ><span class="mdc-list-item__text">Boat Tests</span></a> </div>
</div><div class="mdc-list__item-container">
<div class="mdc-list__item-primary">
<a class="mdc-list-item" href="/boats/maintenance" ><span class="mdc-list-item__text">Maintenance</span></a> </div>
</div><div class="mdc-list__item-container">
<div class="mdc-list__item-primary">
<a class="mdc-list-item" href="/boats/expert-advice" ><span class="mdc-list-item__text">Expert Advice</span></a> </div>
</div> </div> </div><div class="mdc-list__item-container">
<div class="mdc-list__item-primary">
<a class="mdc-list-item mdc-list-item--activated" href="/waterways" ><span class="mdc-list-item__text">Waterways</span></a> <div class="mdc-list-item__meta">
<button class="mdc-icon-button material-icons">arrow_drop_down</button>
</div>
</div>
<div class="mdc-list mdc-list__nested">
<div class="mdc-list__item-container">
<div class="mdc-list__item-primary">
<a class="mdc-list-item" href="/waterways/canal-network" ><span class="mdc-list-item__text">Canal Network</span></a> </div>
</div><div class="mdc-list__item-container">
<div class="mdc-list__item-primary">
<a class="mdc-list-item" href="/waterways/restoration" ><span class="mdc-list-item__text">Restoration</span></a> </div>
</div><div class="mdc-list__item-container">
<div class="mdc-list__item-primary">
<a class="mdc-list-item" href="/waterways/cruises-holidays" ><span class="mdc-list-item__text">Cruises &amp; Holidays</span></a> </div>
</div> </div> </div><div class="mdc-list__item-container">
<div class="mdc-list__item-primary">
<a class="mdc-list-item" href="/subscribe" ><span class="mdc-list-item__text">Subscribe</span></a> <div class="mdc-list-item__meta">
<button class="mdc-icon-button material-icons">arrow_drop_down</button>
</div>
</div>
<div class="mdc-list mdc-list__nested">
<div class="mdc-list__item-container">
<div class="mdc-list__item-primary">
<a class="mdc-list-item" href="https://www.subscriptionsave.co.uk/Products/Leisure-Products/Maintaining-Your-Canal-Boat/PMMMYCB1" target="_blank" rel="noopener" ><span class="mdc-list-item__text">Books</span><span class="material-icons">open_in_new</span></a> </div>
</div><div class="mdc-list__item-container">
<div class="mdc-list__item-primary">
<a class="mdc-list-item" href="/subscribe/tillergraph" ><span class="mdc-list-item__text">Tillergraph</span></a> </div>
</div><div class="mdc-list__item-container">
<div class="mdc-list__item-primary">
<a class="mdc-list-item" href="/subscribe/canal-boat" ><span class="mdc-list-item__text">Canal Boat</span></a> </div>
</div> </div> </div><div class="mdc-list__item-container">
<div class="mdc-list__item-primary">
<a class="mdc-list-item" href="/gift" ><span class="mdc-list-item__text">Gift Subscription</span></a> </div>
</div><div class="mdc-list__item-container">
<div class="mdc-list__item-primary">
<a class="mdc-list-item" href="/newsletters" ><span class="mdc-list-item__text">Newsletters</span></a> </div>
</div><div class="mdc-list__item-container">
<div class="mdc-list__item-primary">
<a class="mdc-list-item" href="https://www.archanthub.co.uk/specialist" target="_blank" rel="noopener" ><span class="mdc-list-item__text">Advertise With Us</span><span class="material-icons">open_in_new</span></a> </div>
</div><div class="mdc-list__item-container">
<div class="mdc-list__item-primary">
<span class="mdc-list-item"><span class="mdc-list-item__text">Your Magazine</span></span>
<div class="mdc-list-item__meta">
<button class="mdc-icon-button material-icons">arrow_drop_down</button>
</div>
</div>
<div class="mdc-list mdc-list__nested mdc-list__nested--open">
<div class="mdc-list__item-container">
<div class="mdc-list__item-primary">
<a class="mdc-list-item" href="https://www.canalboat.co.uk/digital" target="_blank" rel="noopener" ><span class="mdc-list-item__text">Canal Boat</span><span class="material-icons">open_in_new</span></a> </div>
</div><div class="mdc-list__item-container">
<div class="mdc-list__item-primary">
<a class="mdc-list-item" href="https://edition.pagesuite-professional.co.uk//launch.aspx?pbid=d88b2485-4374-4e16-986c-7c7ea6ab57c7" target="_blank" rel="noopener" ><span class="mdc-list-item__text">Tillergraph</span><span class="material-icons">open_in_new</span></a> </div>
</div> </div> </div> </div> </nav>
</div>
<div class="nav-footer">
<ul class="nav-footer__social">
<li>
<a href="https://twitter.com/Canal_Boat"
target="_blank"
rel="noopener"
class="mdc-icon-button fa-icons">
<span class="fab fa-twitter"></span>
</a>
</li>
<li>
<a href="https://www.facebook.com/canalboat"
target="_blank"
rel="noopener"
class="mdc-icon-button fa-icons">
<span class="fab fa-facebook"></span>
</a>
</li>
</ul>
</div>
</aside>
<div class="mdc-drawer-scrim"></div><header class="mdc-top-app-bar lp_header">
<div class="mdc-top-app-bar__row">
<section class="mdc-top-app-bar__section mdc-top-app-bar__section--align-start">
<button class="mdc-icon-button material-icons mdc-top-app-bar__navigation-icon">menu</button>
<div class="mdc-top-app-bar__title">
<a href="/"
title="Canal Boat" >
</a>
</div>
</section>
<section class="mdc-top-app-bar__section mdc-top-app-bar__section--align-end">
<a href="#search-form" class="mdc-icon-button material-icons mdc-top-app-bar__navigation-icon mdc-top-app-bar__navigation-icon--search">search</a>
<div id="login-menu">
<div class="mdc-touch-target-wrapper">
<button class="mdc-button mdc-button--touch login-button">
<span class="mdc-button__ripple"></span>
<span class="mdc-button__label">Log in</span>
<span class="mdc-button__touch"></span>
</button>
</div>
<div class="mdc-touch-target-wrapper">
<button class="mdc-button mdc-button--touch user-button user-button--hidden">
<span class="mdc-button__ripple"></span>
<span class="mdc-button__label user-button__label"></span>
<span class="mdc-button__touch"></span>
</button>
</div>
<div class="mdc-menu-surface--anchor">
<div class="mdc-menu mdc-menu-surface">
<a href="/my-account" class="mdc-list-item user-button--my-account" role="menuitem">
<span class="mdc-list-item__ripple"></span>
<span class="mdc-list-item__graphic"><span class="material-icons" aria-hidden="true">account_circle</span></span>
<span class="mdc-list-item__text">My account</span>
</a>
<div class="mdc-list-item user-button--log-out" role="menuitem">
<span class="mdc-list-item__ripple"></span>
<span class="mdc-list-item__graphic"><span class="material-icons" aria-hidden="true">logout</span></span>
<span class="mdc-list-item__text">Log out</span>
</div>
</div>
</div>
</div>
</section>
<form id="search-form" class="search-form mdc-top-app-bar__section" action="/service/search/canal-boat/3845078" role="search">
<input class="search-form__input" name="query" type="search" value="" placeholder="Search" autocomplete="off"
aria-label="Type your search and press enter." minlength="3" required>
<input type="hidden" id="sortByDate" name="sortByDate" value="true"/>
<button class="search-form__close mdc-icon-button material-icons mdc-top-app-bar__navigation-icon"
type="button">
close
</button>
</form> </div>
</header> <main class="main-content mdc-top-app-bar--fixed-adjust" id="main-content">
<div class="mdc-tab-bar lp_tabbar" role="tablist">
<div class="mdc-tab-scroller">
<div class="mdc-tab-scroller__scroll-area">
<div class="mdc-tab-scroller__scroll-content">
<a href="/news"
class="mdc-tab "
role="tab"
aria-selected="false"
tabindex="0"
target="_self"
>
<span class="mdc-tab__content">
<span class="mdc-tab__text-label">News</span>
</span>
<span class="mdc-tab-indicator ">
<span class="mdc-tab-indicator__content mdc-tab-indicator__content--underline"></span>
</span>
<span class="mdc-tab__ripple"></span>
</a><a href="/boats"
class="mdc-tab "
role="tab"
aria-selected="false"
tabindex="0"
target="_self"
>
<span class="mdc-tab__content">
<span class="mdc-tab__text-label">Boats</span>
</span>
<span class="mdc-tab-indicator ">
<span class="mdc-tab-indicator__content mdc-tab-indicator__content--underline"></span>
</span>
<span class="mdc-tab__ripple"></span>
</a><a href="/waterways"
class="mdc-tab mdc-tab--active"
role="tab"
aria-selected="true"
tabindex="0"
target="_self"
>
<span class="mdc-tab__content">
<span class="mdc-tab__text-label">Waterways</span>
</span>
<span class="mdc-tab-indicator mdc-tab-indicator--active">
<span class="mdc-tab-indicator__content mdc-tab-indicator__content--underline"></span>
</span>
<span class="mdc-tab__ripple"></span>
</a><a href="/subscribe"
class="mdc-tab "
role="tab"
aria-selected="false"
tabindex="0"
target="_self"
>
<span class="mdc-tab__content">
<span class="mdc-tab__text-label">Subscribe</span>
</span>
<span class="mdc-tab-indicator ">
<span class="mdc-tab-indicator__content mdc-tab-indicator__content--underline"></span>
</span>
<span class="mdc-tab__ripple"></span>
</a> </div>
</div>
</div>
</div> <div class="main-content__inner" id="ad-wp-main-container">
<div class="mdc-layout-grid" id="ad-wp-content-container">
<div id="ad-slot-wp" class="advert lp_track advert--desktop-only">
<script type="text/plain" class="optanon-category-C0001">
googletag.cmd.push(function() {
googletag.display('ad-slot-wp');
console.log('display called for: ad-slot-wp');
});
</script>
</div>
<div id="ad-slot-sticky" class="advert lp_track ">
<script type="text/plain" class="optanon-category-C0001">
googletag.cmd.push(function() {
googletag.display('ad-slot-sticky');
console.log('display called for: ad-slot-sticky');
});
</script>
</div>
<div id="ad-slot-lb" class="advert lp_track ">
<script type="text/plain" class="optanon-category-C0001">
googletag.cmd.push(function() {
googletag.display('ad-slot-lb');
console.log('display called for: ad-slot-lb');
});
</script>
</div><div class="flex-grid article-content">
<div class="flex-grid__item flex-grid__item--span-12 flex-grid__item--span-8-desktop">
<div class="lp_breadcrumb"><div class="mdc-typography--body2">
<a class="" href="/" ><span class="mdc-list-item__text">Canal Boat </span></a> <span class="mdc-typography--body2">&gt;</span>
<a class="" href="/waterways" ><span class="mdc-list-item__text">Waterways</span></a> </div></div>
<h1 class="article__title mdc-typography--headline4" >10 of the best: waterside pubs along Peak Forest &amp; Ashton canals</h1>
<div class="article__info-container">
<a class="badge__author-link" href="/martin-ludgate-6244196">
<div class="badge" >
<div class="badge__image">
<span class="material-icons" style="font-size: 30px;">person</span>
</div>
<div class="badge__info">
<p class="badge__name mdc-typography--body2">
Martin Ludgate
</p>
</div>
</div>
</a><div class="article__social lp_social" data-social-share-container>
<a href="#article-comments-coral" class="mdc-icon-button fa-icons article__comment-icon">
<span class="fas fa-comment-alt"></span>
<div class="mdc-typography--button comment-count coral-count" data-coral-notext="true" data-coral-id="cnb-8689168"></div>
</a>
<a data-social-share data-rel="popup" rel="nofollow" class="mdc-icon-button fa-icons"
href="https://www.facebook.com/sharer/sharer.php?u=%url">
<span class="fab fa-facebook"></span>
</a>
<a data-social-share data-rel="popup" rel="nofollow" class="mdc-icon-button fa-icons"
href="http://twitter.com/share?url=%url&text=%title">
<span class="fab fa-twitter"></span>
</a>
<a data-social-share data-rel="popup" rel="nofollow" class="mdc-icon-button fa-icons"
href="https://www.linkedin.com/shareArticle?url=%url">
<span class="fab fa-linkedin"></span>
</a>
<a data-social-share data-rel="popup" rel="nofollow" class="mdc-icon-button fa-icons"
href="https://reddit.com/submit?url=%url&title=%title">
<span class="fab fa-reddit"></span>
</a>
<a href="whatsapp://send/?text=%title%20%url"
rel="nofollow"
data-social-share
data-mobile-only="true"
style="display: none"
class="mdc-icon-button fa-icons">
<span class="fab fa-whatsapp"></span>
</a>
<button id="native-share"
class="mdc-icon-button fa-icons"
style="display: none;">
<span class="fas fa-share-alt"></span>
</button>
</div></div>
<div class="article__published">
<div>
<span class="mdc-typography--subtitle2">Published:</span>
<span class="mdc-typography--body2">11:23 AM February 14, 2022</span>
</div>
<!-- publishDate?datetime?long: 1644837784000 -->
<!-- updateDate?datetime?long: 1644837784000 -->
<!-- timestampDifference: 0 -->
</div>
<div class="item-media">
<div class="" >
<picture>
<!--[if IE 9]><video style="display: none;"><![endif]-->
<source srcset="https://images.cm.archant.co.uk/resource/image/8689462/landscape_ratio16x9/615/346/83204103783c40089cdb8b188df52d44/GL/strawberry-duck-pub-at-clayton.jpg" media="(min-width: 481px) and (max-width: 647px)">
<source srcset="https://images.cm.archant.co.uk/resource/image/8689462/landscape_ratio16x9/987/555/83204103783c40089cdb8b188df52d44/XV/strawberry-duck-pub-at-clayton.jpg" media="(min-width: 648px) and (max-width: 1019px)">
<source srcset="https://images.cm.archant.co.uk/resource/image/8689462/landscape_ratio16x9/640/360/83204103783c40089cdb8b188df52d44/Rp/strawberry-duck-pub-at-clayton.jpg" media="(min-width: 1020px)">
<!--[if IE 9]></video><![endif]-->
<img src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mNkYAAAAAYAAjCB0C8AAAAASUVORK5CYII=" srcset="https://images.cm.archant.co.uk/resource/image/8689462/landscape_ratio16x9/448/252/83204103783c40089cdb8b188df52d44/sj/strawberry-duck-pub-at-clayton.jpg" alt="The Strawberry Duck" class=""
loading="lazy"
title="" />
<noscript>
<img src="https://images.cm.archant.co.uk/resource/image/8689462/landscape_ratio16x9/448/252/83204103783c40089cdb8b188df52d44/sj/strawberry-duck-pub-at-clayton.jpg" alt="The Strawberry Duck" class=""
title="" loading="lazy"
/>
</noscript>
</picture>
</div>
<div class="item-media__info mdc-typography--body2">
<p>
<span class="item-media__caption">
The Strawberry Duck</span>
<span class="item-media__copyright">- Credit: Martin Ludgate</span>
</p>
</div>
</div><div id="ad-slot-inimage" class="advert lp_track ">
<script type="text/plain" class="optanon-category-C0001">
googletag.cmd.push(function() {
googletag.display('ad-slot-inimage');
console.log('display called for: ad-slot-inimage');
});
</script>
</div>
<div id="ad-slot-1x4" class="advert lp_track ">
<script type="text/plain" class="optanon-category-C0001">
googletag.cmd.push(function() {
googletag.display('ad-slot-1x4');
console.log('display called for: ad-slot-1x4');
});
</script>
</div>
<div class="article__detail-text mdc-typography--body1" >
<p><em>Our insiders guide to 10 of the best waterside pubs to be found along Peak Forest &amp; Ashton canals. Read our cruise guide for <a href="https://www.canalboat.co.uk/waterways/cruise-guide-peak-forest-and-ashton-canals-8647816" target="_blank" rel="nofollow">the Peak Forest &amp; Ashton canals here</a></em></p><p><strong>The Strawberry Duck, Clayton</strong><br/>07931 170307<br/>By Lock 13<br/><em>Smart, friendly, traditional pub with modern extension, canalside outdoor seating, real ale, live music at weekends<br/><a href="https://www.facebook.com/StrawberryDuckClayton/" target="_blank" rel="nofollow">More info</a></em></p><p><strong>The Boundary, Guide Bridge</strong><br/>0161 612 0754<br/>By Bridge 26<br/><em>Gastropub with wide range of food but also welcomes those wanting a drink. Real ale, garden<br/><a href="https://theboundaryinn.co.uk/" target="_blank" rel="nofollow">More info</a></em></p><p><strong>The Cheshire Ring,  Manchester Road Hyde</strong> <br/>07917 055629<br/>Just east of Bridge 6<br/><em>Name commemorates the canal circuit. Selection of real ales from local microbreweries, ciders and European beers. Monthly Laurel &amp; Hardy film night. Closed Mon-Thu lunchtimes<br/><a href="https://m.facebook.com/profile.php?id=167378513305610" target="_blank" rel="nofollow">More info</a></em></p><p><strong>The Spread Eagle, Hatherlow, Romiley</strong><br/>0161 494 5723<br/>2 mins west of the aqueduct over Green Lane<br/><em>Large family friendly pub with good value food and range of real ales<br/><a href="https://www.facebook.com/Spreadeaglepub/" target="_blank" rel="nofollow">More info</a></em></p><p><strong>The Navigation, Marple</strong><br/>Just west of Bridge 18<br/><em>Lively community local with real ale and food<br/><a href="https://www.facebook.com/thenavigationmarple/" target="_blank" rel="nofollow">More info</a></em></p><p><strong>The Samuel Oldknow, Market Street, Marple</strong><br/>07766 301627<br/>5 mins west of Bridge 18 and left<br/><em>Quirky little pub in converted shop, named after businessman involved in building the canal, good selection of real ales and ciders, snacks (local pies)<br/><a href="https://www.samueloldknow.co.uk/" target="_blank" rel="nofollow">More info</a></em></p><p><strong>The Rock Tavern, Wirksmoor Road, New Mills</strong><br/>01663 746430<br/>5 mins north east from Bridge 28, left into Torvale Road and right<br/><em>Back street local tucked away on way to Riverside Park. Real ale, garden<br/><a href="https://www.facebook.com/rocktavernnewmills" target="_blank" rel="nofollow">More info</a></em></p><p><strong>Soldier Dick, Buxton Road, Furness Vale</strong><br/>01663 611010<br/>5 mins west of Bridge 31 and right<br/><em>Comfortable traditional pub with open fire, range of real ales and garden<br/><a href="https://www.soldierdick.co.uk/en-GB" target="_blank" rel="nofollow">More info</a></em></p><p><strong>The Navigation, Bugsworth</strong><br/>01663 732072<br/>By the upper basin<br/><em>Family friendly traditional multi-room pub, real ale, good value food all day, outdoor seating and play area<br/><a href="https://navigationinn.co.uk/" target="_blank" rel="nofollow">More info</a></em></p><p><strong>The Goyt, Bridge Street, Whaley Bridge</strong><br/>01663 732710<br/>5 mins south from basin along Canal Street and left<br/><em>Friendly town local with selection of real ales and garden<br/><a href="https://www.facebook.com/goytinn" target="_blank" rel="nofollow">More info</a></em></p>
</div> </div>
<div class="flex-grid__item flex-grid__item--span-12 flex-grid__item--span-4-desktop order-5-phone">
<section>
<h2 class="section-component__heading mdc-typography--headline4">Don&#39;t Miss</h2>
<div class="mdc-layout-grid__inner">
<div class="mdc-layout-grid__cell mdc-layout-grid__cell--span-4-phone mdc-layout-grid__cell--span-9-tablet mdc-layout-grid__cell--span-12-desktop">
<div class="mdc-card mdc-card--medium mdc-card--horizontal-phone mdc-card--horizontal-tablet mdc-card--horizontal-desktop" >
<a href="/waterways/brand-new-boating-show-for-2022-boatlife-live-8567542" class="mdc-card__primary-action" tabindex="0">
<div class="mdc-card__media" >
<picture>
<!--[if IE 9]><video style="display: none;"><![endif]-->
<source srcset="https://images.cm.archant.co.uk/resource/image/8567618/portrait_ratio1x1/138/138/9717529a7d47825fa7c9dc05c2df0ca0/vn/boatlife-live-2022-brand-detail-logo-white-bg.jpg" media="(min-width: 481px) and (max-width: 647px)">
<source srcset="https://images.cm.archant.co.uk/resource/image/8567618/portrait_ratio1x1/138/138/9717529a7d47825fa7c9dc05c2df0ca0/vn/boatlife-live-2022-brand-detail-logo-white-bg.jpg" media="(min-width: 648px) and (max-width: 1019px)">
<source srcset="https://images.cm.archant.co.uk/resource/image/8567618/portrait_ratio1x1/138/138/9717529a7d47825fa7c9dc05c2df0ca0/vn/boatlife-live-2022-brand-detail-logo-white-bg.jpg" media="(min-width: 1020px)">
<!--[if IE 9]></video><![endif]-->
<img src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mNkYAAAAAYAAjCB0C8AAAAASUVORK5CYII=" srcset="https://images.cm.archant.co.uk/resource/image/8567618/portrait_ratio1x1/138/138/9717529a7d47825fa7c9dc05c2df0ca0/vn/boatlife-live-2022-brand-detail-logo-white-bg.jpg" alt="BoatLife Live logo" class=""
loading="lazy"
title="" />
<noscript>
<img src="https://images.cm.archant.co.uk/resource/image/8567618/portrait_ratio1x1/138/138/9717529a7d47825fa7c9dc05c2df0ca0/vn/boatlife-live-2022-brand-detail-logo-white-bg.jpg" alt="BoatLife Live logo" class=""
title="" loading="lazy"
/>
</noscript>
</picture>
</div>
<div class="mdc-card__primary">
<p class="overline mdc-typography--overline">
<span class="overline__label_color">Sponsored </span> </p>
<div class="mdc-card__title-container">
<h4 class="mdc-card__title mdc-typography--headline6">Brand new boating show for 2022: BoatLife Live!</h4>
</div>
<div class="mdc-card__info">
<!-- author override: false -->
<div class="badge" >
<div class="badge__info" >
<p class="badge__name mdc-typography--body2">Martin Ludgate</p>
</div>
<span class="badge__image--icon material-icons">person</span>
</div> </div>
</div>
</a>
</div> </div>
<div class="mdc-layout-grid__cell mdc-layout-grid__cell--span-4-phone mdc-layout-grid__cell--span-9-tablet mdc-layout-grid__cell--span-12-desktop">
<div class="mdc-card mdc-card--medium mdc-card--horizontal-phone mdc-card--horizontal-tablet mdc-card--horizontal-desktop" >
<a href="/boats/space-saving-solutions-for-canal-boats-liveaboards-8374148" class="mdc-card__primary-action" tabindex="0">
<div class="mdc-card__media" >
<picture>
<!--[if IE 9]><video style="display: none;"><![endif]-->
<source srcset="https://images.cm.archant.co.uk/resource/image/8374942/portrait_ratio1x1/138/138/121eef27caf69a336ffe0fc49b1138e6/Zy/gettyimages-523829342.jpg" media="(min-width: 481px) and (max-width: 647px)">
<source srcset="https://images.cm.archant.co.uk/resource/image/8374942/portrait_ratio1x1/138/138/121eef27caf69a336ffe0fc49b1138e6/Zy/gettyimages-523829342.jpg" media="(min-width: 648px) and (max-width: 1019px)">
<source srcset="https://images.cm.archant.co.uk/resource/image/8374942/portrait_ratio1x1/138/138/121eef27caf69a336ffe0fc49b1138e6/Zy/gettyimages-523829342.jpg" media="(min-width: 1020px)">
<!--[if IE 9]></video><![endif]-->
<img src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mNkYAAAAAYAAjCB0C8AAAAASUVORK5CYII=" srcset="https://images.cm.archant.co.uk/resource/image/8374942/portrait_ratio1x1/138/138/121eef27caf69a336ffe0fc49b1138e6/Zy/gettyimages-523829342.jpg" alt="Narrow boat moored on a stretch of the Grand Union Canal in Warwickshire, England, United Kingdom." class=""
loading="lazy"
title="" />
<noscript>
<img src="https://images.cm.archant.co.uk/resource/image/8374942/portrait_ratio1x1/138/138/121eef27caf69a336ffe0fc49b1138e6/Zy/gettyimages-523829342.jpg" alt="Narrow boat moored on a stretch of the Grand Union Canal in Warwickshire, England, United Kingdom." class=""
title="" loading="lazy"
/>
</noscript>
</picture>
</div>
<div class="mdc-card__primary">
<p class="overline mdc-typography--overline">
<span class="overline__label_color">Sponsored </span> </p>
<div class="mdc-card__title-container">
<h4 class="mdc-card__title mdc-typography--headline6">Narrowboat Living: Space-Saving Solutions</h4>
</div>
<div class="mdc-card__info">
<!-- author override: true -->
<div class="badge" >
<div class="badge__info" >
<p class="badge__name mdc-typography--body2">GJW Direct</p>
</div>
<img class="badge__image" alt="Logo Icon" src="/resource/crblob/7304876/6fd813df2f96a102901510eb4f48206a/logo-icon-png-data.png" loading="lazy" />
</div> </div>
</div>
</a>
</div> </div>
<div class="mdc-layout-grid__cell mdc-layout-grid__cell--span-4-phone mdc-layout-grid__cell--span-9-tablet mdc-layout-grid__cell--span-12-desktop">
<div class="mdc-card mdc-card--medium mdc-card--horizontal-phone mdc-card--horizontal-tablet mdc-card--horizontal-desktop" >
<a href="/waterways/canal-network/cruise-guide-the-gloucester-sharpness-canal-8605794" class="mdc-card__primary-action" tabindex="0">
<div class="mdc-card__media" >
<picture>
<!--[if IE 9]><video style="display: none;"><![endif]-->
<source srcset="https://images.cm.archant.co.uk/resource/image/8605836/portrait_ratio1x1/138/138/85f2d0c5a660333a9065b8d38447b316/fR/cnb1121-cruise-guide-g-s-19-gloucester-img-2630.jpg" media="(min-width: 481px) and (max-width: 647px)">
<source srcset="https://images.cm.archant.co.uk/resource/image/8605836/portrait_ratio1x1/138/138/85f2d0c5a660333a9065b8d38447b316/fR/cnb1121-cruise-guide-g-s-19-gloucester-img-2630.jpg" media="(min-width: 648px) and (max-width: 1019px)">
<source srcset="https://images.cm.archant.co.uk/resource/image/8605836/portrait_ratio1x1/138/138/85f2d0c5a660333a9065b8d38447b316/fR/cnb1121-cruise-guide-g-s-19-gloucester-img-2630.jpg" media="(min-width: 1020px)">
<!--[if IE 9]></video><![endif]-->
<img src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mNkYAAAAAYAAjCB0C8AAAAASUVORK5CYII=" srcset="https://images.cm.archant.co.uk/resource/image/8605836/portrait_ratio1x1/138/138/85f2d0c5a660333a9065b8d38447b316/fR/cnb1121-cruise-guide-g-s-19-gloucester-img-2630.jpg" alt="On the canal south of Gloucester Docks, with a new main road liftbridge in the distance" class=""
loading="lazy"
title="" />
<noscript>
<img src="https://images.cm.archant.co.uk/resource/image/8605836/portrait_ratio1x1/138/138/85f2d0c5a660333a9065b8d38447b316/fR/cnb1121-cruise-guide-g-s-19-gloucester-img-2630.jpg" alt="On the canal south of Gloucester Docks, with a new main road liftbridge in the distance" class=""
title="" loading="lazy"
/>
</noscript>
</picture>
</div>
<div class="mdc-card__primary">
<p class="overline mdc-typography--overline">
</p>
<div class="mdc-card__title-container">
<h4 class="mdc-card__title mdc-typography--headline6">Cruise guide: the Gloucester &amp; Sharpness Canal</h4>
</div>
<div class="mdc-card__info">
<!-- author override: false -->
<div class="badge" >
<div class="badge__info" >
<p class="badge__name mdc-typography--body2">Martin Ludgate</p>
</div>
<span class="badge__image--icon material-icons">person</span>
</div> </div>
</div>
</a>
</div> </div>
<div class="mdc-layout-grid__cell mdc-layout-grid__cell--span-4-phone mdc-layout-grid__cell--span-9-tablet mdc-layout-grid__cell--span-12-desktop">
<div class="mdc-card mdc-card--medium mdc-card--horizontal-phone mdc-card--horizontal-tablet mdc-card--horizontal-desktop" >
<a href="/waterways/heritage-spotter-the-purton-hulks-8606184" class="mdc-card__primary-action" tabindex="0">
<div class="mdc-card__media" >
<picture>
<!--[if IE 9]><video style="display: none;"><![endif]-->
<source srcset="https://images.cm.archant.co.uk/resource/image/8606296/portrait_ratio1x1/138/138/56492003165719d3415fce278320d920/Zr/cnb1121-cruise-guide-extra-purton-hulks-01-img-2540.jpg" media="(min-width: 481px) and (max-width: 647px)">
<source srcset="https://images.cm.archant.co.uk/resource/image/8606296/portrait_ratio1x1/138/138/56492003165719d3415fce278320d920/Zr/cnb1121-cruise-guide-extra-purton-hulks-01-img-2540.jpg" media="(min-width: 648px) and (max-width: 1019px)">
<source srcset="https://images.cm.archant.co.uk/resource/image/8606296/portrait_ratio1x1/138/138/56492003165719d3415fce278320d920/Zr/cnb1121-cruise-guide-extra-purton-hulks-01-img-2540.jpg" media="(min-width: 1020px)">
<!--[if IE 9]></video><![endif]-->
<img src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mNkYAAAAAYAAjCB0C8AAAAASUVORK5CYII=" srcset="https://images.cm.archant.co.uk/resource/image/8606296/portrait_ratio1x1/138/138/56492003165719d3415fce278320d920/Zr/cnb1121-cruise-guide-extra-purton-hulks-01-img-2540.jpg" alt="barge &#39;Harriett&#39; of the Purton Hulks" class=""
loading="lazy"
title="" />
<noscript>
<img src="https://images.cm.archant.co.uk/resource/image/8606296/portrait_ratio1x1/138/138/56492003165719d3415fce278320d920/Zr/cnb1121-cruise-guide-extra-purton-hulks-01-img-2540.jpg" alt="barge &#39;Harriett&#39; of the Purton Hulks" class=""
title="" loading="lazy"
/>
</noscript>
</picture>
</div>
<div class="mdc-card__primary">
<p class="overline mdc-typography--overline">
<span
class="overline__category">Canal Heritage</span> </p>
<div class="mdc-card__title-container">
<h4 class="mdc-card__title mdc-typography--headline6">Heritage spotter: the Purton Hulks</h4>
</div>
<div class="mdc-card__info">
<!-- author override: false -->
<div class="badge" >
<div class="badge__info" >
<p class="badge__name mdc-typography--body2">Martin Ludgate</p>
</div>
<span class="badge__image--icon material-icons">person</span>
</div> </div>
</div>
</a>
</div> </div>
</div>
</section>
<div id="ad-slot-mpu-1--desktop"></div>
</div>
<div class="flex-grid__item flex-grid__item--span-12">
<div id="ad-slot-lb-2" class="advert lp_track"></div>
</div>
<div class="flex-grid__item flex-grid__item--span-12 flex-grid__item--span-8-desktop">
<div id="ad-slot-mpu-6" class="advert lp_track"></div>
<div id="ad-slot-mpu-7" class="advert lp_track"></div>
<div id="ad-slot-mpu-8" class="advert lp_track"></div>
<div id="ad-slot-mpu-9" class="advert lp_track"></div>
<div id="ad-slot-mpu-10" class="advert lp_track"></div>
<aside id="OutbrainContainer">
<div class="OUTBRAIN"
data-ob-contentUrl="https://www.canalboat.co.uk/waterways/10-best-pubs-along-peak-forest-ashton-canals-8689168"
data-widget-id="AR_1"
data-ob-installation-key="ARCHA2B5LD0KOJB7DQHPJJB86"
>
</div>
</aside>
<script>
let observer = new MutationObserver(mutationRecords => {
for(let mutation of mutationRecords) {
for(let node of mutation.addedNodes) {
if (!(node instanceof HTMLElement)) continue;
if (node.matches('div[class*="ob-smartfeed-joker"]')) {
console.log("Coremedia > advert.ftl > mutation observer: div ID " + node.firstChild.id + " moved into OB Joker.");
let childDivId = node.firstChild.id;
if(childDivId.includes('article-comments-coral')){
if((typeof tp.pianoId.isUserValid() !=='undefined') && tp.pianoId.isUserValid()){
let pianoToken = tp.pianoId.getToken();
convertToken(pianoToken);
} else {
let nullToken="";
initCoral(nullToken)
}
} else if (childDivId.includes('ad-slot-mpu')){
fetchAdByDivId(childDivId);
} else {
}
}
}
}
});
observer.observe(document.querySelector("#OutbrainContainer"), {
childList: true,
subtree: true,
});
</script>
<div id="article-comments-coral" class="lp_disqus"></div>
<script type="text/javascript">
let awsEndpoint = "https://wxpuf3c49j.execute-api.eu-west-2.amazonaws.com/Prod";
let coralRootUrl = "https://comments.archant.co.uk";
let coralSrc = "https://comments.archant.co.uk/assets/js/embed.js";
let coralEmbed;
tp = window["tp"] || [];
tp.push(["init", function() {
if(tp.pianoId.isUserValid()){
let pianoToken = tp.pianoId.getToken();
convertToken(pianoToken);
} else {
let nullToken="";
initCoral(nullToken)
}
}]);
function convertToken(pianoToken) {
let myHeaders = new Headers();
myHeaders.append("Content-Type", "text/plain");
myHeaders.append("Accept", "*/*");
let raw = pianoToken;
let requestOptions = {
method: 'POST',
headers: myHeaders,
body: raw,
redirect: 'follow'
};
fetch(awsEndpoint, requestOptions)
.then(response => {
return (response.text());
})
.then(result => {
console.log(result);
initCoral(result);
})
}
function initCoral(token){
let d = document, s = d.createElement('script');
s.src = coralSrc;
s.async = false;
s.defer = true;
s.onload = function() {
coralEmbed = Coral.createStreamEmbed({
bodyClassName: "CNB",
id: "article-comments-coral",
autoRender: true,
rootURL: coralRootUrl,
storyID: "cnb-8689168",
storyURL: window.location.origin + window.location.pathname,
accessToken: token,
events: function(events) {
events.on("loginPrompt", function() {
pianoLogin();
});
events.on("signOut.success", function() {
pianoLogout();
});
events.on("signOut.error", function() {
console.error("Coral: signOut error");
});
}
});
};
(d.head || d.body).appendChild(s);
}
</script>
</div>
</div></div>
</div>
<footer class="footer lp_footer">
<div class="footer-block footer-block--links">
<ul>
<li><a href="/newsletters" >Newsletters</a></li>
<li><a href="/about-us" >About Us</a></li>
<li><a href="/contact-us" >Contact Us</a></li>
<li><a href="https://www.archanthub.co.uk/specialist" target="_blank" rel="noopener">Advertise With Us</a></li>
<li><a href="/all-topics" >All Topics</a></li>
<li><a href="/complaints" >Complaints</a></li>
<li><a href="https://www.archant.co.uk/join" target="_blank" rel="noopener">Jobs at Archant</a></li>
<li><a href="https://www.archant.co.uk/contibutors-charter" target="_blank" rel="noopener">Contributors Charter</a></li>
<li><a href="https://www.archant.co.uk/articles/cookies-policy" target="_blank" rel="noopener">Cookie Policy</a></li>
<li><a href="https://www.archant.co.uk/articles/privacy-policy" target="_blank" rel="noopener">Privacy Policy</a></li>
<li><a href="https://www.archant.co.uk/articles/terms-conditions/" target="_blank" rel="noopener">Terms &amp; Conditions</a></li>
<li><a href="https://www.archant.co.uk" target="_blank" rel="noopener">Archant</a></li>
<li><a href="#" class="optanon-toggle-display">Manage Cookies</a></li>
</ul>
</div>
<div class="footer-block footer-block--badges">
<img alt="IPSO Regulated" src="/resource/crblob/7304810/92f83a2a0e0906a5977c6c256f81db1b/ipso-regulated-white-png-data.png"/>
</div>
<div class="footer-block footer-block--social">
<ul>
<li><a rel="noopener noreferrer" target="_blank" href="https://twitter.com/Canal_Boat" class="mdc-icon-button fa-icons"><span class="fab fa-twitter"></span></a></li>
<li><a rel="noopener noreferrer" target="_blank" href="https://www.facebook.com/canalboat" class="mdc-icon-button fa-icons"><span class="fab fa-facebook"></span></a></li>
</ul>
</div>
<div class="footer-block footer-block--copyright">2022 &copy; Archant Community Media Ltd</div>
<div class="pianolow"></div>
<div id="backgroundForStickyAdOverFooter" style="height: 90px">&nbsp;</div>
</footer> </main><script src="/resource/themes/archant-shared/js/commons-7305068-5.js" ></script><script src="/resource/themes/archant-shared/js/archant-shared-7305066-10.js" ></script></body></html>
